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Conventions
The following conventions are used in this manual:

» The » symbol leads you through nested menu items 
and dialog box options to a final action. The sequence 
File»Page Setup»Options directs you to pull down the 
File menu, select the Page Setup item, and select 
Options from the last dialog box.

♦ The ♦ symbol indicates that the following text applies 
only to a specific product, a specific operating system, 
or a specific software version.

This icon denotes a note, which alerts you to important 
information.

This icon denotes a caution, which advises you of 
precautions to take to avoid injury, data loss, or a 
system crash. When this symbol is marked on the 
hardware product, refer to the Safety Information section 
for information about precautions to take.

bold Bold text denotes items that you must select or click in 
the software, such as menu items and dialog box options.

italic Italic text denotes emphasis or a cross reference.

module Refers to an NI PXI/PCI-5401, NI PXI-5404, 
NI PXI/PCI-5411, NI PXI-5421, or NI PXI/PCI-5431.

monospace Text in this font denotes text or characters that you 
should enter from the keyboard, sections of code, 
programming examples, and syntax examples. This font 
is also used for disk drives, paths, directories, filenames 
and extensions, and functions.

NI signal Refers to an NI PXI/PCI-5401, NI PXI-5404,
generator(s) NI PXI/PCI-5411, NI PXI-5421, or NI PXI/PCI-5431.
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Introduction
This document explains how to install, configure, and test National 
Instruments signal generators to generate various waveforms. For more 
information about your module, such as features and programming, refer to 
the NI Signal Generators Help at Start»Programs»National Instruments»
NI-FGEN»Documents»NI Signal Generators Help.

For your NI signal generator specifications, refer to the specifications 
document included with your module.

For free downloads of the most current versions of documentation and 
example programs, visit ni.com/instruments.

Unpack the Module
The NI signal generators ship in an antistatic package to prevent electrostatic 
damage. Electrostatic discharge (ESD) can damage several components on 
the module.

Caution Never touch the exposed pins of connectors.

To avoid damage in handling the module, take the following precautions:

• Ground yourself using a grounding strap or by holding a grounded 
object.

• Touch the antistatic package to a metal part of your computer chassis 
before removing the module from the package.

Remove the module from the package and inspect it for loose components or 
any sign of damage. Notify NI if the module appears damaged in any way. 
Do not install a damaged module into your computer.

Store the module in the antistatic envelope when not in use.
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Verify the Components
To install and use your module, make sure you have the following:

❑ If developing applications, one of the following application development 
environments (ADEs) and its documentation:

– NI LabVIEW

– LabWindows™/CVI™

– Microsoft Visual Basic or Visual C/C++

❑ NI-FGEN 2.0 or later

❑ NI 5431 only—NI Composite Video Generator CD

❑ NI signal generator and its documentation

❑ A PXI chassis, a PXI/SCXI combination chassis, or a PXI/CompactPCI 
chassis—with a controller and the chassis documentation

OR

❑ A desktop computer with its documentation

❑ 1/8 in. flathead screwdriver

❑ Cables appropriate for use with your module

Install the Software
The NI-FGEN CD, included with your kit, contains the instrument driver for 
all NI signal generators. Also included on the NI-FGEN CD is the FGEN Soft 
Front Panel (SFP). The FGEN SFP is a fast, easy, and interactive tool that 
helps you to start working with the NI signal generators quickly.

To install NI-FGEN, complete the following steps: 

1. (optional) Install an ADE, such as NI LabVIEW or LabWindows/CVI, 
if you are developing an application for the NI signal generator.

2. Insert the NI-FGEN CD into your CD drive, and follow the instructions 
in the installation window.

Note If the installation window does not appear, navigate to the 
CD drive, double-click the drive, and double-click setup.exe.

♦ For NI 5431 modules only, complete the following steps:

3. Insert the NI Composite Video Generator CD into your CD drive. 

4. Click Install in the installation window that appears, and follow the 
instructions in the dialog boxes.
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Install the Hardware
To prevent damage to the module caused by ESD or contamination, handle 
the module using the edges or the metal bracket. Refer to the Safety 
Information section for more information. To ensure optimal forced-air 
cooling, refer to the guidelines in the Maintain Forced-Air Cooling Read Me 
First included in your NI signal generator kit.

PXI Installation
To install the module in either a PXI chassis, a PXI/SCXI combination 
chassis, or a PXI/CompactPCI chassis, refer to Figure 1 and complete the 
following steps:

1. Verify that NI-FGEN is installed.

2. Power off and unplug the PXI chassis.

3. Insert the module into an available PXI slot until the ejector handle locks 
in the up position, and tighten the captive screw(s).

4. Plug in and power on the PXI chassis.

Figure 1.  PXI Installation
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PCI Installation
To install the module, refer to Figure 2 and complete the following steps:

1. Verify that NI-FGEN is installed.

2. Power off and unplug the PC.

3. Remove the PC cover.

4. Insert the module into an open PCI slot.

5. Secure the module with the screw provided in the kit.

6. Replace the PC cover.

7. Plug in and power on the PC.

Figure 2.  PCI Installation
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Configure Your Module
To configure and test your module, complete the following steps:

1. Launch Measurement & Automation Explorer (MAX).

2. Double-click Devices and Interfaces to see the list of installed devices. 
MAX automatically detects the module you installed. 

Note If you do not see your module listed, press <F5> to refresh. 
If your module is still not listed, repeat the steps in the Install the 
Hardware section. For more information about using MAX, refer 
to the available help files within MAX.

3. Right-click your NI signal generator in the list, and select Properties to 
launch the Configuring Device window. 

4. Notice the device number and resources assigned to the module, 
and write it down. You may need this number later.

Note If you are using the MXI-3 interface to control the PXI 
chassis, the MXI-3 Optimization Application must be run prior 
to using the NI signal generator. By default, this application runs 
automatically when Windows starts. If you have an initialization 
or performance issue with your module, or if you are not certain 
that the application ran, select Start»Programs»National 
Instruments MXI-3»MXI-3 Optimization to run the application. 
If you continue to have initialization or performance issues, refer 
to the MXI-3 documentation at Start»Programs»National 
Instruments MXI-3, or visit NI Technical Support at 
ni.com/support.

5. Click Test Resources to test the module resources. A dialog box appears 
and indicates if the module has passed the resource test.

Note If the module does not pass the test, repeat the steps in the 
Install the Hardware section. If the device still does not pass the 
test, visit NI Technical Support at ni.com/support.

6. Click Close when you finish testing the module. 

7. Click OK in the Configuring Device window.

8. Exit MAX.
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Connect Signals
This section contains front panel connector figures and connector description 
tables that describe the signal connection options for NI signal generators.

NI PXI-5401
The NI PXI-5401 has four connectors—two BNC connectors and two SMB 
connectors, as shown in Figure 3. Signal descriptions are listed in Table 1. 

Figure 3.  NI PXI-5401 Front Panel Connectors

Table 1.  NI PXI-5401 Connectors

Connector Access Function

ARB OUT Output Provides the waveform output.

SYNC OUT Output Provides a TTL version of the sine waveform 
being generated at the ARB OUT connector.

EXT TRIG Input Accepts a TTL-level signal that you can use to 
start or step through a waveform generation.

PLL REF Input Accepts a PLL reference clock from an external 
source and can frequency lock the NI PXI-5401 
internal clock to the external reference clock.

ARB OUT

SYNC OUT

EXT TRIG

PLL REF

LOCK ACCESS

NI PXI-5401
Arbitrary Function Generator
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NI PCI-5401
The NI PCI-5401 has four connectors—three SMB connectors and 
one 50-pin digital connector, as shown in Figure 4. Signal descriptions 
are listed in Table 2.

Figure 4.  NI PCI-5401 Front Panel Connectors

Table 2.  NI PCI-5401 Connectors

Connector Access Function

ARB Output Provides the waveform output.

SYNC Output Provides a TTL version of the sine waveform being 
generated at the ARB connector.

PLL IN Input Accepts a PLL reference clock from an external 
source and can frequency lock the NI PCI-5401 
internal clock to the external reference clock.

PATTERN OUT Input Supplies the external trigger input to the device. 
Refer to the NI Signal Generators Help for 
connector pin assignments and signal descriptions.
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NI PXI-5404
The NI PXI-5404 has five SMB connectors, as shown in Figure 5. Signal 
descriptions are listed in Table 3.

Figure 5.  NI PXI-5404 Front Panel Connectors

Table 3.  NI PXI-5404 Connectors

Connector Access Function

SINE Output Provides a sine waveform of the desired frequency 
output.

CLOCK Output Provides a TTL version of the sine waveform 
being generated at the SINE connector.

PFI 0 Input/
Output

Accepts either a TTL signal to start waveform 
generation, or provides an output to 
synchronize—or trigger—other devices at 
a certain time within waveform generation.

SINE

REF
OUT

REF
IN

PFI 0

CH 0

CLOCK

ACCESS ACTIVE

NI PXI-5404
100 MHz Freq Source



NI Signal Generators Getting Started Guide 12 ni.com

NI PXI-5411/5431
NI PXI-5411/5431 have six connectors—two BNC connectors, 
three SMB connectors, and one 50-pin digital connector, as shown 
in Figure 6. Signal descriptions are listed in Table 4. 

Figure 6.  NI PXI-5411/5431 Front Panel Connectors

REF OUT Output Routes signals from the PXI backplane clock, 
PXI trigger lines, or a divided-down version of 
the internal NI 5404 clock.

REF IN Input Accepts a PLL reference clock from an external 
source and can frequency lock the NI PXI-5404 
internal clock to the external reference clock.

Table 3.  NI PXI-5404 Connectors (Continued)

Connector Access Function

ARB OUT

SYNC OUT

EXT TRIG

MARKER OUT

PLL REF

LOCK ACCESS

DIGITAL
PATTERN

NI PXI-5411
Arbitrary Waveform Generator

VIDEO OUT

SYNC OUT

EXT TRIG

MARKER OUT

PLL REF

LOCK ACCESS

VIDEO
DIGITAL

PATTERN

NI PXI-5431
Video Generator
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Table 4.  NI PXI-5411/5431 Connectors

Connector Access Function

ARB/
VIDEO OUT

Output Provides the waveform output.

SYNC OUT Output Provides a TTL version of the waveform being 
generated at the ARB/VIDEO OUT connector.

EXT TRIG Input Accepts a TTL-level signal that you can use to start 
or step through a waveform generation.

MARKER OUT Output Sends a TTL-level signal that you can set at any 
point in the waveform being generated. You can 
use this signal to synchronize or trigger other 
devices at a certain time within waveform 
generation.

PLL REF Input Accepts a PLL reference clock from an 
external source and can frequency lock the 
NI PXI-5411/5431 internal clock to the external 
reference clock. You can also use this connector 
as a source of the module sample clock from an 
external device.

DIGITAL 
PATTERN/
VIDEO 
DIGITAL 
PATTERN

Input/
Output

Routes 16-bit digital pattern outputs, digital 
pattern clock output, marker output, external 
trigger input, and +5 V power output. Refer to 
the NI Signal Generators Help for connector pin 
assignments and signal descriptions.
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NI PCI-5411/5431
The NI PCI-5411/5431 have four connectors—three SMB connectors and 
one 50-pin digital connector, as shown in Figure 7. Signal descriptions are 
listed in Table 5.

Figure 7.  NI PCI-5411/5431 Front Panel Connectors

Table 5.  NI PCI-5411/5431 Connectors

Connector Access Function

ARB Output Provides the waveform output.

SYNC Output Provides a TTL version of the sine waveform being 
generated at the ARB connector.

PLL IN Input Accepts a PLL reference clock from an 
external source and can frequency lock the 
NI PCI-5411/5431 internal clock to the external 
reference clock.

PATTERN OUT Input/
Output

Routes the 16-bit digital pattern outputs, digital 
pattern clock output, marker output, external 
trigger input, and +5 V power output. Refer to 
the NI Signal Generators Help for connector pin 
assignments and signal descriptions.
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NI PXI-5421
The NI PXI-5421 has five connectors—four SMB connectors and one 68-pin 
male VHDCI connector, as shown in Figure 8. Signal descriptions are listed 
in Table 6. 

Figure 8.  NI PXI-5421 Front Panel Connectors
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Generate Waveforms
To programmatically generate waveforms, use NI-FGEN. Refer to the 
NI Signal Generators Help for more information about using NI-FGEN 
to generate waveforms.

To interactively generate waveforms, use the FGEN SFP.

♦ NI 5431—In addition to generating waveforms with the NI 5431, you can 
generate video signals using the NI Video Generator Wizard. To generate 
a video signal with your NI 5431, complete the steps in the Generate a 
Video Signal with the NI 5431 section of this document.

Generate a Standard Waveform
♦ NI 5401/5404/5411/5431—To generate a standard waveform with your 

module, complete the following steps:

1. Launch MAX.

2. Verify that the module you want to test appears under Devices and 
Interfaces.

Table 6.  NI PXI-5421 Connectors

Connector Access Function

CH 0 Output Provides the waveform output.

CLK IN Input Accepts a PLL reference clock from an external 
source and can frequency lock the NI PXI-5421 
internal clock to the external reference clock. You 
can also use this connector as a source of the module 
sample clock from an external device.

PFI 0 Input/
Output

Accepts a trigger from an external source that can 
start or step through waveform generation, or can 
route signals out from several clock, event, and 
trigger sources. Refer to the NI Signal Generators 
Help for signal descriptions and routing 
information.

PFI 1 Input/
Output

Accepts a trigger from an external source that can 
start or step through waveform generation, or can 
route signals out from several clock, event, and 
trigger sources. Refer to the NI Signal Generators 
Help for signal descriptions and routing 
information.

Digital Data & 
Control (DDC)

Input/
Output

Routes the 16-bit digital pattern outputs, digital 
pattern clock output, trigger outputs, trigger inputs, 
and a clock input. Refer to the NI Signal Generators 
Help for connector pin assignments and signal 
descriptions.
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Note If the module is not in the Devices and Interfaces list, press 
<F5> to refresh. If the module is still not in the list, repeat the 
instructions in the Configure Your Module section.

3. Launch the FGEN SFP by one of the following two methods:

• Select Start»Programs»National Instruments»NI-FGEN»FGEN 
Soft Front Panel.

• Select Tools»Soft Front Panels»NI-FGEN Soft Front Panel from 
the menu bar in MAX.

4. Verify that the module you installed appears on the FGEN SFP display, 
as shown in Figure 9. 

Figure 9.  FGEN SFP Display with the NI PXI-5411 Selected

Note If your device is not listed, or if you have more than one type 
of NI signal generator installed, select Edit»Device Configuration. 
In the Device Configuration dialog box, shown in Figure 10, click 
the Device listbox drop-down arrow, and select your module from 
the list. Click OK to close the Device Configuration dialog box.

Figure 10.  Device Configuration Dialog Box
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5. Verify that the standard function waveform mode button  
is selected.

6. Select the frequency, amplitude, offset, and type of waveform generated 
that you want to generate. 

7. Click the run button  to initiate waveform generation. 

The FGEN SFP default settings instruct the NI 5401/5404/5411/5431 
to generate a continuous sine wave at a frequency of 1 MHz, with a 
peak-to-peak amplitude of 1 V into a 50 Ω load, and no offset. Adjust the 
sine waveform settings in the FGEN SFP to match your needs. For more 
information about the FGEN SFP, launch the FGEN SFP and then press 
<Ctrl-H>.

Generate an Arbitrary Waveform
♦ NI 5411/5421/5431—To generate an arbitrary waveform with your 

module, complete the following steps:

1. Launch MAX.

2. Verify that the module you want to test appears under Devices and 
Interfaces.

Note If the module is not in the Devices and Interfaces list, 
press <F5> to refresh. If the module is still not in the list, repeat 
the instructions in the Configure Your Module section.

3. Select Start»Programs»National Instruments»NI-FGEN»FGEN 
Soft Front Panel.

4. Verify that the module you installed appears on the FGEN SFP display, 
as shown in Figure 11.

♦ NI 5411/5431—Verify that the single arbitrary waveform output 
button located in the Mode section is selected, as shown in Figure 11.

♦ NI 5421—The signal arbitrary waveform output button located in the 
Mode section is automatically selected.
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Figure 11.  FGEN SFP Display with NI PXI-5421 Selected

Note If your device is not listed, or if you have more than one type 
of NI signal generator installed, select Edit»Device Configuration. 
In the Device Configuration dialog box, shown in Figure 10, click 
the Device listbox drop-down arrow, and select your module from 
the list. Click OK to close the Device Configuration dialog box.

5. To download a waveform to the module onboard memory, click in the 
Current Waveform Pattern listbox, and select Load Waveform from 
disk. The File Load dialog box and Select File window both open. 
The Select File window displays waveform example files.

Note You can also download a waveform by selecting File»Load 
New Waveform. The default location for example waveforms is 
\\Program Files\IVI\Drivers\niFgen\Waveform\
Examples.

6. Select arbMode-sine.lvm, and click OK. A preview of the waveform 
launches. You can close or minimize the waveform preview window.

7. In the File Load dialog box, select one of the following settings from the 
Waveform drop-down list:

♦ NI-PXI-5411/5431—sine, 16MHz@40MS/s

♦ NI-PXI-5421—sine, 40MHz@100MS/s

8. Click OK in the File Load dialog box.

9. Click the run button  to initiate waveform generation. To optimize 
the sine wave shape, select Edit»Device Configuration, and change the 
filter settings.
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The FGEN SFP default settings instruct the NI 5411/5421/5431 to generate 
a continuous sine wave, with a peak-to-peak amplitude of 1 V into a 50 Ω 
load, and no offset. Adjust the sine waveform settings in the FGEN SFP to 
match your needs. For more information about the FGEN SFP, launch the 
FGEN SFP, then press <Ctrl-H>.

Generate a Video Signal with the NI 5431
To programmatically generate video signals, use the NI Composite Video 
Generator in LabVIEW. For information about programmatically generating 
video signals, refer to the NI 5431 Composite Video Generator Help. Access 
this help file by selecting Help»NI5431 from the LabVIEW VI menu bar.

To interactively generate a video signal using the NI Video Generator 
Wizard, complete the following steps:

1. Launch MAX.

2. Verify that the module you want to test appears under Devices and 
Interfaces.

Note If the module is not in the Devices and Interfaces list, press 
<F5> to refresh. If the module is still not in the list, repeat the 
instructions in the Configure Your Module section.

3. Launch the NI Video Generator Wizard, shown in Figure 12, by selecting 
Start»Programs»National Instruments Composite Video 
Generator»Video Generator Wizard.

Figure 12.  NI Video Generator Wizard Dialog Box
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4. Generate a video signal based on a bitmap image using the factory 
settings by completing the following steps while referring to Figure 12.

a. Verify that the Device ID is set to the correct value—the device 
number previously configured in MAX.

b. Select Load BMP file and compute video data.

c. Click Browse.

d. Double-click the appropriate directory from the following choices:

• For NTSC users, double-click the 640x480 or the 1044x480 
directory.

• For PAL and SECAM users, double-click the 768x576 or the 
1040x576 directory.

Note For information about video data file formats, refer to the 
NI Signal Generators Help.

e. Double-click any of the example .bmp files. The bitmap image file 
path appears in the BMP Input File Path control box.

f. Select Use factory settings. This option applies the default video 
parameters to the video signal you want to generate.

g. Select M-NTSC, Standard-PAL, or SECAM, depending on the 
video format you want to generate.

h. Select Download video data file. This option downloads the binary 
video data from your computer to the NI 5431 module.

Note To display the .bmp file on your computer monitor, enable 
Display BMP.

i. Click Finish. The Processing dialog box appears displaying the 
processing status.

Based on the .bmp file you selected, the NI Video Generator Wizard 
calculates either NTSC, PAL, or SECAM video data, downloads the 
calculated data to the NI 5431 module, and automatically starts generating 
the video signal on the VIDEO OUT connector.
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FCC/Canada Radio Frequency Interference 
Compliance

Determining FCC Class
The Federal Communications Commission (FCC) has rules to protect 
wireless communications from interference. The FCC places digital 
electronics into two classes. These classes are known as Class A (for use in 
industrial-commercial locations only) or Class B (for use in residential or 
commercial locations). All NI products are FCC Class A products.

Depending on where it is operated, this Class A product could be 
subject to restrictions in the FCC rules. (In Canada, the Department of 
Communications (DOC), of Industry Canada, regulates wireless interference 
in much the same way.) Digital electronics emit weak signals during normal 
operation that can affect radio, television, or other wireless products.

All Class A products display a simple warning statement of one paragraph in 
length regarding interference and undesired operation. The FCC rules have 
restrictions regarding the locations where FCC Class A products can be 
operated.

Consult the FCC Web site at www.fcc.gov for more information.

FCC/DOC Warnings
This equipment generates and uses radio frequency energy and, if not 
installed and used in strict accordance with the instructions in this manual 
and the CE marking Declaration of Conformity1, may cause interference to 
radio and television reception. Classification requirements are the same 
for the FCC and the Canadian DOC. 

Changes or modifications not expressly approved by NI could void the user’s 
authority to operate the equipment under the FCC Rules.

Class A

Federal Communications Commission
This equipment has been tested and found to comply with the limits for a 
Class A digital device, pursuant to part 15 of the FCC Rules. These limits are 
designed to provide reasonable protection against harmful interference when 
the equipment is operated in a commercial environment. This equipment 
generates, uses, and can radiate radio frequency energy and, if not installed 
and used in accordance with the instruction manual, may cause harmful 

1  The CE marking Declaration of Conformity contains important supplementary information and 
instructions for the user or installer.
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interference to radio communications. Operation of this equipment in a 
residential area is likely to cause harmful interference in which case the 
user is required to correct the interference at their own expense.

Canadian Department of Communications
This Class A digital apparatus meets all requirements of the Canadian 
Interference-Causing Equipment Regulations.

Cet appareil numérique de la classe A respecte toutes les exigences du 
Règlement sur le matériel brouilleur du Canada.

Compliance to EU Directives
Readers in the European Union (EU) must refer to the manufacturer’s 
Declaration of Conformity (DoC) for information1 pertaining to the 
CE marking compliance scheme. The manufacturer includes a DoC for most 
hardware products except for those bought from OEMs. In addition, DoCs 
are usually not provided if compliance is not required, for example 
electrically benign apparatus or cables.

To obtain the DoC for this product, click Declarations of Conformity 
Information at ni.com/hardref.nsf/. This Web site lists the DoCs by 
product family. Select the appropriate product family, followed by your 
product, and a link to the DoC appears in Adobe Acrobat format. Click 
the Acrobat icon to download or read the DoC.

Safety Information
This section contains important safety information that you must follow 
when installing and using an NI signal generator.

Do not operate the module in a manner not specified in this document. 
Misuse of the module can result in a hazard. You can compromise the safety 
protection built into the module if the module is damaged in any way. If the 
module is damaged, return it to National Instruments (NI) for repair.

Do not substitute parts or modify the module except as described in this 
document. Use the module only with the chassis, modules, accessories, and 
cables specified in the installation instructions. You must have all covers and 
filler panels installed during operation of the module.

Do not operate the module in an explosive atmosphere or where there may 
be flammable gases or fumes. If you must operate the module in such an 
environment, it must be in a suitably rated enclosure.

1  The CE marking Declaration of Conformity contains important supplementary information and 
instructions for the user or installer.
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If you need to clean the module, use a soft, nonmetallic brush. Make sure that 
the module is completely dry and free from contaminants before returning it 
to service.

Operate the module only at or below Pollution Degree 2. Pollution is foreign 
matter in a solid, liquid, or gaseous state that can reduce dielectric strength or 
surface resistivity. The following is a description of pollution degrees:

• Pollution Degree 1 means no pollution or only dry, nonconductive 
pollution occurs. The pollution has no influence.

• Pollution Degree 2 means that only nonconductive pollution occurs in 
most cases. Occasionally, however, a temporary conductivity caused by 
condensation must be expected.

• Pollution Degree 3 means that conductive pollution occurs, or dry, 
nonconductive pollution occurs that becomes conductive due to 
condensation.

You must insulate signal connections for the maximum voltage for which the 
module is rated. Do not exceed the maximum ratings for the module. Do not 
install wiring while the module is live with electrical signals. Do not remove 
or add connector blocks when power is connected to the system. Avoid 
contact between your body and the connector block signal when hot 
swapping modules. Remove power from signal lines before connecting them 
to or disconnecting them from the module.

Operate the module at or below the installation category1 marked on the 
hardware label. Measurement circuits are subjected to working voltages2 and 
transient stresses (over voltage) from the circuit to which they are connected 
during measurement or test. Installation categories establish standard 
impulse withstand voltage levels that commonly occur in electrical 
distribution systems. The following is a description of installation categories:

• Installation Category I is for measurements performed on circuits not 
directly connected to the electrical distribution system referred to as 
MAINS3 voltage. This category is for measurements of voltages from 
specially protected secondary circuits. Such voltage measurements 
include signal levels, special equipment, limited-energy parts of 
equipment, circuits powered by regulated low-voltage sources, 
and electronics.

1  Installation categories, also referred to as measurement categories, are defined in electrical safety 
standard IEC 61010-1.

2  Working voltage is the highest rms value of an AC or DC voltage that can occur across any 
particular insulation.

3  MAINS is defined as a hazardous live electrical supply system that powers equipment. Suitably 
rated measuring circuits may be connected to the MAINS for measuring purposes.
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• Installation Category II is for measurements performed on circuits 
directly connected to the electrical distribution system. This category 
refers to local-level electrical distribution, such as that provided 
by a standard wall outlet (for example, 115 AC voltage for U.S. or 
230 AC voltage for Europe). Examples of Installation Category II are 
measurements performed on household appliances, portable tools, 
and similar modules.

• Installation Category III is for measurements performed in the building 
installation at the distribution level. This category refers to measurements 
on hard-wired equipment such as equipment in fixed installations, 
distribution boards, and circuit breakers. Other examples are wiring, 
including cables, bus bars, junction boxes, switches, socket outlets in the 
fixed installation, and stationary motors with permanent connections to 
fixed installations.

• Installation Category IV is for measurements performed at the primary 
electrical supply installation (<1,000 V). Examples include electricity 
meters and measurements on primary overcurrent protection devices and 
on ripple control units.

Technical Support Resources

NI Web Support
National Instruments Web support is your first stop for help in solving 
installation, configuration, and application problems and questions. Online 
problem-solving and diagnostic resources include frequently asked 
questions, knowledge bases, product-specific troubleshooting wizards, 
manuals, drivers, software updates, and more. Web support is available 
through the Technical Support section of ni.com.

A DoC is our claim of compliance with the Council of the European 
Communities using the manufacturer’s declaration of conformity. This 
system affords the user protection for electronic compatibility (EMC) 
and product safety. You can obtain the DoC for your product at 
ni.com/hardref.nsf. If your product supports calibration, you can 
obtain the calibration certificate at ni.com/calibration.

Worldwide Support
National Instruments has offices located around the world to help address 
your support needs. You can access our branch office Web sites from the 
Worldwide Offices section of ni.com. Branch office Web sites provide 
up-to-date contact information, support phone numbers, email addresses, 
and current events. 



NI Signal Generators Getting Started Guide 26 ni.com

If you have searched the technical support resources on our Web site and still 
cannot find the answers you need, contact your local office or National 
Instruments corporate. For telephone support in the United States, dial 
512 795 8248. For telephone support outside the United States, contact 
your local branch office: 

Australia 1800 300 800, Austria 43 0 662 45 79 90 0, 
Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599, 
Canada (Calgary) 403 274 9391, Canada (Montreal) 514 288 5722, 
Canada (Ottawa) 613 233 5949, Canada (Québec) 514 694 8521, 
Canada (Toronto) 905 785 0085, Canada (Vancouver) 514 685 7530, 
China 86 21 6555 7838, Czech Republic 420 2 2423 5774, 
Denmark 45 45 76 26 00, Finland 385 0 9 725 725 11, 
France 33 0 1 48 14 24 24, Germany 49 0 89 741 31 30, 
Greece 30 2 10 42 96 427, India 91 80 51190000, 
Israel 972 0 3 6393737, Italy 39 02 413091, Japan 81 3 5472 2970, 
Korea 82 02 3451 3400, Malaysia 603 9131 0918, 
Mexico 001 800 010 0793, Netherlands 31 0 348 433 466, 
New Zealand 1800 300 800, Norway 47 0 66 90 76 60, 
Poland 48 0 22 3390 150, Portugal 351 210 311 210, 
Russia 7 095 238 7139, Singapore 65 6226 5886, Slovenia 386 3 425 4200, 
South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 
Sweden 46 0 8 587 895 00, Switzerland 41 56 200 51 51, 
Taiwan 886 2 2528 7227, Thailand 662 992 7519, 
United Kingdom 44 0 1635 523545
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